Segfault when trying to search for files 2020

Felix Yuan 11 лет назад обновлен Jon Skinner 11 лет назад 4
Ran Sublime for the first time. Mounted a folder as part of a project. Tried to start searching for a file. This is the below output:

main.cc:403 value_loaded loading bindings
theme.cc:188 texture_loaded theme loaded
main.cc:198 callback_finished app ready
snippet_manager.cpp:104 attachSnippets loaded 918 snippets
io_requests.cc:343 run scanning /home/fyuan/xdev4/bt
io_requests.cc:348 run scanned /home/fyuan/xdev4/bt
file_buffer_source.cpp:270 cancelRead Unable to wait for read thread to exit
Segmentation fault

Co-worker was using build 2011.02.03 which worked. He upgraded and it no longer works.


Fixed in build 2023
I regularly have Build 2020 (and the previous 3 builds) crash when using the find anything prompt to find files in a remote folder mounted through SSHFS. (And by regularly I mean ridiculously regularly... every 2-3 searches).

This is on a Ubuntu 10.10 desktop environment.
This should be fixed in the current dev build, at http://www.sublimetext.com/dev. If you could give it a go and confirm for me, that'd be great.
Works great! Seems to be able to search.
I haven't had it crash yet since installing the update. Thumbs up so far.
Fixed in build 2023

Сервис поддержки клиентов работает на платформе UserEcho