+1

ST3 "shell": true not working in Build

Prem Suraj 5 years ago 0
This is my sublime-build file
{
   "shell":true,
   "cmd": ["cd $project_path && c:\\Windows\\Microsoft.NET\\Framework\\v4.0.30319\\MSBuild.exe && $project_path\\debug\\vctest.exe"]
}

This is the output I get when running the build
The filename, directory name, or volume label syntax is incorrect.
[Finished in 0.1s with exit code 1]
[cmd: ['cd D:\\TFS\\Scrum\\iWhiz\\Dev2.3 && c:\\Windows\\Microsoft.NET\\Framework\\v4.0.30319\\MSBuild.exe && D:\\TFS\\Scrum\\iWhiz\\Dev2.3\\debug\\vctest.exe']]
[dir: D:\TFS\Scrum\iWhiz\Dev2.3]
[path: C:\Program Files\Common Files\Microsoft Shared\Windows Live;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;c:\Program Files\Intel\DMIX;C:\Program Files\NTRU Cryptosystems\NTRU TCG Software Stack\bin\;C:\Program Files\Intel\Services\IPT\;C:\Program Files\Dell\Dell Data Protection\Access\Advanced\Wave\Gemalto\Access Client\v5\;C:\Program Files\Windows Live\Shared;C:\Program Files\Common Files\Acronis\SnapAPI\;C:\Program Files\CMake 2.8\bin;C:\Program Files\Microsoft SQL Server\100\Tools\Binn\;C:\Program Files\Microsoft SQL Server\100\DTS\Binn\;%TFSPowerToolDir%;%BPADir%;C:\Program Files\Prio;C:\program files\microsoft visual studio 10.0\Team tools\performance tools;C:\Program Files\Common Files\Autodesk Shared\;C:\Windows\Microsoft.NET\Framework\v4.0.30319;]

I suspect that the command "shell":true is not having any effect on the build system.