can't save any file

Jac Fitzgerald 8 years ago updated 8 years ago 2

I have a file open in ST2. I have no other programs running on the machine, which I just rebooted. I edit the file and hit Ctrl-S, I get the error 'can't save file'. Opening a random other file gets the same error on save. Editing the same files in any other program (notepad, Visual Studio) works fine as expected. Process Explorer tells me that this file is not open in any other program. I also found that a number of other people have run into this same dialog: http://www.sublimetext.com/forum/viewtopic.php?f=3&t=9240 with no known explanation. 

I installed ST2 a few weeks ago and it worked up until a few days ago, and has not saved any files since then. I have rebooted the machine and closed every other program there is. The machine is running Windows Server 2012.

I noticed that I get this error every time I try and save a file that is under version control (specifically, I'm using TFS). Files not under version control are ok.

And now I also found that installing this plugin (https://bitbucket.org/CDuke/sublime-tfs/src) for tfs makes it save successfully.