Increase responsiveness for projects stored on network drives

Nathan Walasek 7 years ago updated 6 years ago 3

All of my project files are hosted on a shared network drive, which is mapped to a drive letter in Windows 7. After opening the project in ST2, I attempt to navigate through directories and many times (especially on larger projects) it appears as though that directory is empty (the toggle-arrow changes, but no files/folders appear). Only after waiting for several minutes do the files appear.

yeah I've got a project mapped to show local source, build server folder, and deployed code, but only local source is remotely responsive speedwise. if I open the same folder(s) in windows explorers it's instant.
Try this, it appears to be helping me, http://twigstechtips.blogspot.com/2013/02/sublime-...
even though it talks about a different network issue, it seems to have improved performance.

remedy this by going to:
  • Preferences
  • Settings - User
  • Add in this line
"ignore_inodes": true
Save and restart ST2. The subfolders SHOULD show up. If not, remove the folder from your project and add them again.
Unfortunately, I already have "ignore_inodes" set to true.

I have figured out a temporary fix for the blank file tree issue in the sidebar. Going to Project > New Workspace for Project seems to fix the sidebar (until I switch projects...then I need to repeat this process again).