Can't open file with Sublime as default in Open With shell

Rob Graham 9 lat temu Ostatnio zmodyfikowane przez RIJO JOSEPH 4 lat temu 6
I had older version installed before without issues, but since I updated to the most recent release, no matter what I do, I cannot get Sublime Text to show up in the Open With window of other programs. I browse for the programs .exe and check "Always use the selected program" but it wont load into the list of other programs. I can no longer associate my php files to Sublime. I've uninstalled and reinstalled Sublime too. Didn't help.

I've even gone through file association window in Control Panel but it just provides the same Open Files display. Sublime.exe WILL NOT load itself into the list. I now have to manually open my php files with sublime until I can get a fix for this.

I know there is an option during install to add a shell option to open with Sublime Text 2 when you right click a file, but this doesn't associate files to Sublime by default. It's very frustrating.
Fixed it!

Apparently if you've installed sublime before in another location of your hard drive(s) and install a newer version elsewhere, you'll have some registry settings left over that don't get cleaned up by the program when you uninstall. I opened up regex and just did a full sweep search for "sublime" and deleted everything i could find, including folders that had instructions inside to use the older sublime path.

Installed sublime again and wallah, works again.

FWIW, I had had a portable version of Sublime Text 2 running in my Dropbox, and decided to stop using that at my work computer due to ST2 retaining open files from previous sessions (when combined with Dropbox, ST2 @ work was showing files I had had open in ST2 @ home, which I didn't need to have happen). So at work, I excluded the ST2 folder from being synced in Dropbox (using the selective sync feature).

So to fix the issue of this thread, I searched the registry for "sublime_text_2.exe", and every time I saw a reference to the now non-existent Dropbox ST2, I simply changed the path to point to the local ST2 I had installed elsewhere.

I have the same problem, where did you find the settings, the uninstall didn't delete?
I used the registry repair feature of ccleaner to search and repair my registry issues. If I remember correctly ccleaner found one issue with a broken "open with" reference that pointed to a portable version of sublime text that I had deleted.

Technically you should be able to do it manually like Rob did using regedit but I couldn't tell you exactly what to search for.

Figured it out. In the registry, the "HKEY_CLASSES_ROOT\Applications\sublime_text.exe\shell" key had the (Default) value set to something along the lines of "this is an intentionally empty blank value" (no, I didn't copy the value before deleting it, but it was something to that effect). Yes, really - go figure. Deleting that made Sublime Text suddenly appear in the Open With... list of installed programs dialog box.

I just fixed the registry issues using the CCleaner application and it just worked fine.