+3

UnicodeEncodeError: 'ascii' codec can't encode character

Michal Mikoláš 7 years ago • updated 7 years ago 3
Hello, in some packages, I got an error: 

Exception in thread Thread-13:
Traceback (most recent call last):
  File ".\threading.py", line 532, in __bootstrap_inner
  File ".\Package Control.py", line 1890, in run
  File ".\Package Control.py", line 1759, in make_package_list
  File ".\Package Control.py", line 1121, in list_available_packages
  File ".\Package Control.py", line 1066, in list_repositories
  File ".\Package Control.py", line 175, in get_repositories
  File ".\Package Control.py", line 148, in fetch_channel
  File ".\Package Control.py", line 1007, in download_url
  File ".\Package Control.py", line 602, in download
  File ".\urllib2.py", line 126, in urlopen
  File ".\urllib2.py", line 391, in open
  File ".\urllib2.py", line 409, in _open
  File ".\urllib2.py", line 369, in _call_chain
  File ".\Package Control.py", line 92, in https_open
  File ".\urllib2.py", line 1133, in do_open
  File ".\httplib.py", line 910, in request
  File ".\httplib.py", line 947, in _send_request
  File ".\httplib.py", line 904, in endheaders
  File ".\httplib.py", line 776, in _send_output
  File ".\httplib.py", line 735, in send
  File ".\Package Control.py", line 71, in connect
  File ".\ssl.py", line 350, in wrap_socket
  File ".\ssl.py", line 113, in __init__
UnicodeEncodeError: 'ascii' codec can't encode character u'\xe1' in position 23: ordinal not in range(128)

This error shows me, when I use plugin SublimePackageControl>install, or plugin Nettuts-Fetch>Fetch>PackageFile, and maybe in some other plugins. Because of that, I think that error is in SublimeText 2 and not in packages directly. 

I use SublimeText 2 beta, build 2181. 

Thanks
I have the same probem ...
I think that there in name of yours folders must be some characters with diacritics. Check it! Bye
Yes, you are right! I had diacritics in path to SublimeText2. Thank you ;-)