Sidebar doesn't update on Mac OSX randomly

Kurtis R.G. 9 years ago updated by Kristen Grote 7 years ago 8
  • OS: Mac OSX 10.6.8
  • Build: Sublime Text 2 2165 (and at least the last two versions)

When I delete a file from the sidebar, it should remove itself from the file list.
When I rename a file in the sidebar, it should remove itself from the file list and then add the new file.
When I add a file to the project it should add itself to the file list.

The sidebar doesn't seem to be updating when file events happen (rename, delete, create, move).

Steps Taken To Fix:
  • I've restarted the application.
  • I've deleted the application.
  • I've deleted ALL the file created by the application (including two sneaky ones in ~/Library).
  • I've reinstalled the application.
  • I've restarted my computer.
  • I've looked at the console.

Nothing, nada, zip. No dice!

This has now happened twice. The first time it randomly stopped after deleting all of my project files. Doing that again hasn't fixed it.
This was fixed by updating Dropbox and restarting. It also seemed to affect Guard, a fsevent-based ruby library, and other fsevent things.
It happened again, and I'm the latest version of Dropbox.

I've noticed this often lately, too. I think it might happen when you have a large project open with a lot of files to keep track of? The only way I can fix it seems to be quit and restart ST2.

Actually, it doesn't seem to have anything to do with the size of the project. I'm seeing this all the time now. Even after quit and re-open ST2, and open a small project. Rename a file, delete a file, add a file, none of it updates the sidebar.

This is happening with me absolutely all the time with all my projects. The only way to get the sidebar to update is to restart ST2, which I have to do every time something in my project directory changes. I haven't tried to reinstall ST2 yet but it's next on my list.


FYI there's a Project->Refresh Folders menu item, may save you from having to restart ST2.

This behavior happens for me specifically for files/folders that are stored in my Dropbox folder.

I suspect it's due the the large number of code repositories with .git directories in my Dropbox causing Dropbox to register an insane amount of FSEvent watches, thus blocking Sublime Text from registering watches.

This would explain why, as Kurtis R.G. mentioned 2 years ago, other file watch using software like Grunt had problems, and why his updating, and thus restarting, Dropbox temporarily fixed the problem).

Here are the file and directory counts for my Dropbox folder. I'm going to try to trim down and see if that helps.

% find ~/Dropbox -type f -print | wc -l


% find ~/Dropbox -type d -print | wc -l


I'm also having this problem on Mac OSX Mavericks (10.8.5) and Sublime Text 2 (2.0.2) - I also had the same problem with Sublime Text 3.

My project is stored in Dropbox and it does contain a Git repository. This seems to be a Mac-specific problem, however, because until 2 weeks ago I was using Sublime Text to work with this same project on Windows 7 with no issues.