Disable autocomplete when typing string

David Baumgold 9 лет назад обновлен Spencer Alger 9 лет назад 1
ST2's autocomplete is very useful, but when suggestions pop up in the wrong context, they can be very annoying. I will never use autocomplete when I am typing a string in my code, and it's distracting when they pop up in those cases -- especially when I'm writing a docstring in Python. Please disable this behavior.

Anyone else who thinks this would be useful can just edit the sublime setting "auto_complete_selector" to look something like this:

    "auto_complete_selector": "source - (comment, string.quoted)"

From the sublime console I used the following command to get the scope name of the current selection:


And this to test my selectors against different selections:


        sublime.active_window().active_view().sel()[0].begin(), "source - (comment, string.quoted)"


Сервис поддержки клиентов работает на платформе UserEcho