Bug in osx 'look up in dictionary" behaviour

Matthew Raso-Barnett 10 years ago updated 10 years ago 1
Usually in OSX applications you can look up words in text by hovering the mosue cursor over the word and pressing 'cmd+crtl+D' which will highlight the word and show a drop down dictionary window with the definition of that word. Alternatively you can right click the word and there is often a menu item to "Look up...".

In build 2112 (and maybe before?) the keyboard shortcut behaviour triggers the dictionary lookup still, although it actually highlights and looks up the word after the one the cursor is hovering over. The contextual menu item doesn't appear so perhaps this feature isn't supposed to be supported.

Here is a picture, where my mouse cursor is actually over the word 'this' (although you cannot see it).  

Additionally the highlighting of the word is misaligned with the underlying text:

This issue was partially fixed in 2113. Sorry to be pedantic, but the highlighting of the word is still not quite 'native' in its behaviour as it still doesn't respect the font style/size of the underlying word. This becomes clearer to see by calling the dictionary with the font set to a reasonably large size (although is clearly visible even at size 12) - 

Here is the same in textedit: