0

Spellcheck does not respect "word_separators" setting.

joseph 2 years ago • updated 2 years ago 1

Currently, if words are joined with any unicode character other than a space or something included in the "word_separators" setting, it will be considered one entity by the spellchecker and thus be highlighted as misspelled.

For instance, the following are all treated as misspelled:

“forgottenalthough” (Using the <U+2014 EM DASH> character)

“Perfectionists” (Using the <U+2019 RIGHT SINGLE QUOTATION MARK> character)

‣ etcetera…


The solution should be to simply add those characters to the "word_separators" setting. However, the spellchecker does not respect that setting, even though it affects the rest of ST3.

I propose either this bug be fixed or a more complete spellchecker be implemented to resolve such issues.