0
Oleg Smolsky 4 years ago • updated 4 years ago 2

I often select a bunch of text (a few words on the active line) and then type text thus replacing the selection. This is a standard thing on Windows yet Sublime tries to be smart and adds two parenthesis around the selection when I press "(".


Could you add a setting to prevent this trait please?

Well, you can set "auto_match_enabled" to false in your user settings file. That will turn off all auto matching, i.e. for parenthesis, brackets, braces, and quotes. If you want to keep some but not all of the auto matches, you can copy the corresponding key bindings and change them to suit your work flow.