Symstym 4 years ago • updated by Brandon Schlueter 3 months ago 11

I got this fancy new 2560x1440 display and when I run Sublime Text 2 with the window at maximum size, the render update is remarkably slow. This by itself is not too bad but this has the effect of making key repeat very slow. I'm on a MacBook Pro w/ 2.53 GHz Core 2 Duo, plenty of memory.

I've got the same problem with a much more modest 1440x900 resolution, and only happens since I upgraded from snow leopard to lion. Shrinking the window to 1/4 of the screen size keyboard repeat is normal, but even at half screen size it is noticeably slower, gets really annoying at fullscreen.
Yes, please.  On my iMac, I can routinely out-type Sublime.
Same issue here. The keyboard repeat rate is unbearibly slow unless I shrink my window down very small. This isn't an issue with any other applications running on my system including NetBeans IDE, LibreOffice, etc.
I hope this gets fixed for real, but as a temporary workaround, I've found that deleting Settings/Session.sublime_session sometimes dramatically decreases the slowness.

Having the same issue, deleting my session works for about 10 minutes before it goes back to being incredibly lag prone, running at a quarter of the screen size

What plugins has everyone who has been experiencing this got installed?  I no longer seem to have the problem, so I think it might have been a plugin that I tried out and then uninstalled which put something bad into my session state.

It comes and goes. This issue is now quite rare, but from time to time it still occurs, and I haven't been able to figure out what triggers it. Definitely not a plugin issue — I haven't added or removed any plugins in a very long time.


Same here when running Retina MBP on high res scaled. Resizing the window solves it, but that sucks :P

I get the same thing. It's worse when the file is unsaved (and it updates the tab title with the text in the document). But it's definitely related to screen size as well.

Same here. Retina display. Plugins... Alignment, Bracket Highlighter. I use a custom TTF font also. Still...

I'm still experiencing this issue, FOUR YEARS LATER, and about to switch back to vim...