0
posted by Mm256 , updated 3 months ago , 2

I keep getting the wrong output after running TidyHtml from the command palette. 


This is the original HTML string:

Australasia’s ecology.
and this is the code output:
Australasia’s ecology. 
which in the browser shows up like this:

Australasia’s ecology.

I played a bit with the Tidy HTML Sublime setting options, see http://w3c.github.com/tidy-html5/quickref.html but with no avail.


Is there a way to tell Tidy HTML to leave these special characters untouched?

Thank you

Vote
+1
It's doing this because it doesn't think your file is UTF-8, but it has UTF-8 bytes in it. Stuff this in your TidyHTML5.sublime-settings, should fix it:

{
    "TidyHTML":{
        "options": [
            {"char-encoding": "utf8"}
        ]
    }
}
That is great news for me Joey!

It works like a charm now.

Thank you very much.