-1
posted by Ian Nieves , updated 2 years ago , 4
High contrast theme for working on the beach or in the sun... ALSO a high contrast cursor (insertion point) so that I can see where the cursor actually is.  Perhaps put a glowing ring around it...  Currently it is so skinny it is impossible to see.
Vote
For a high contrast theme, explore some of the existing color schemes in Preferences->Color Schemes, such as 'Eiffel'.


For the cursor, the closest built-in option available seems to be setting this in your Preferences.sublime-settings:


"caret_style": "smooth",
"wide_caret": true,

Also you might want to check out the SublimeBlockCursor plugin, which tries to mimic a "real" block cursor.

Oops.. sorry.. i posted the comment above in the wrong place..
any idea what im doing wrong with this cursor stuff???
I have followed all advice and had a bad experience.

1) It turns out that SublimeBlockCursor cannot be installed via packages.  You have to be lucky enough to realize that and install in manually via git clone.  I did that.  Then it is totally unclear where to add the text snippet to actually turn that thing on.  I added it to a few different locations within my :
~/Library/Application Support/Sublime Text 2/Packages/Color Scheme - Default/Monokai Bright.tmTheme

2) After that fail, I went through all the themes to evaluate them for actual high contrast.  I found none of them to actually be high contrast.

3) Then I tried adding the cared style stuff you mentioned below to my:
~/Library/Application Support/Sublime Text 2/Packages/User/Preferences.sublime-settings
I restarted ST, and nothing.

I will assume that since I saw no error messages (and failing silently is a no no), that I actually inserted the necessary text in the right places in #1 and #3 above.

This is not the experience users should have.  Perhaps consider supporting cursor styles or some other simple built in solution to this.

If im doing something totally wrong, id love to know... but otherwise this didn't work.
I restarted ST after each attempt, and nothing.  
The block cursor style is only available in COMMAND MODE when using vintage (i.e. you can navigate the document, but can't make changes with the block cursor). what you want is block cursor in the INSERT MODE. i haven't been able to find this one myself yet. but to see what that one looks like in preferences remove "Vintage" from the ignored packages, save, then hit ESC button to go into command mode (to go back into insert mode press "i").