+6
Ryan Park 6 years ago • updated by Jon Skinner 6 years ago 2

When connecting my MacBook to a non-Apple external monitor and using it as my only display, the text is anti-aliased incorrectly.


To reproduce,


1. Connect a MacBook to a non-Apple display (I was using a Samsung SyncMaster).

2. Make sure there are no Apple displays running including the laptops monitor.

3. Quit Sublime Text 2 if it is running.

4. Open or restart Sublime Text 2.

5. Note that the text's rendering is different and incorrect from the standard rendering of text in OS X.


Some notes:

I've found that when Sublime remains open while switching between monitors the method it anti-alias' the text remains. For example, if the rendering is incorrect and I switch to a display that traditionally renders it correctly, it will remain incorrect until I quit and restart Sublime Text 2.

Answer

Answer
This appears to be an OS X quirk - information is at http://slackrw.wordpress.com/2010/07/31/mac-os-x-10-6-snow-leopard-re-enable-lcd-font-smoothing-for-some-monitors-via-macosxhints-com/
Answer
This appears to be an OS X quirk - information is at http://slackrw.wordpress.com/2010/07/31/mac-os-x-10-6-snow-leopard-re-enable-lcd-font-smoothing-for-some-monitors-via-macosxhints-com/
I can confirm that this actually happens. to see the problem I've attached a screenshot of ST2 and Texmate on a Samsung SyncMaster with the same color-scheme and font
Seeing similar problems...

and the previously posted solution is this: