+1
aristidesfl 6 years ago • updated by Vincent Côté-Roy 6 years ago 4
Mac OS X Lion
Build: 2091

find_selected_text behaves like false by default, despite behind set to true in the default preferences.

the only way making it true, is setting it in the User preferences
It works, you just have to set it in your user preferences - the default value is overridden by the osx specific default
I understand. 

The workflow usually is to scan the default file preferences file for interesting settings, and copy the ones which need to be changed to the user file preferences.
If the settings set in the default's, might be overridden by OSX specific defaults, and there is no indication of that on the preferences file, neither a entry on the preferences menu, it can cause confusion and misconfiguration.
It's quite deceiving.

In the meanwhile, where can I find the OSX specific defaults file?

Thanks

Nevermind, I found it: ~/Library/Application%20Support/Sublime%20Text%202/Packages/Default/Base%20File%20(OSX).sublime-settings

In any case, there should be a menu item for this or at least a mention about this in the Normal Defaults
this workaround does work. 

however i would concur that it his highly confusing that the global settings are overriden like this.

also, i am hard-pressed to find a reason why this should not be a default, or what's different about osx that it would be disabled there.