+3

American keyboard layout in find window

Christian Davén 5 years ago • updated by Bartosz Prusak 4 years ago 3
I'm using Sublime Text 2.0.1 on Swedish Windows 7 with Swedish keyboard layout, but when opening the "Find" window in Sublime, it treats my keyboard as if it was an American layout.

E.g. when I'm pressing the "-" key, the character "/" appears.
It seems like it wasn't limited to the find window, but rather that Sublime Text had switched keyboard layouts completely. It works ok now after I restarted the program.
+2
This is likely to be a Windows issue itself. Sometimes it likes switching keyboard layouts randomly (well, almost). I think the default hotkey to change the keyboard locale is "Alt-Shift" - at least that's what I use to switch between German and Japanese.

Edit: You can check the current keyboard locale in the taskbar if you enabled it. This setting is window-depended, it changes for every window.

Thank you for the comment - Alt+Shift changes the layout, and it seems for me that Sublime has its own mechanisms for layout of keyboard, but with similar shortcuts.

I got a pretty peculiar layout, though: quotation mark worked like tilde (as in you need to press it and then one more key - including tilde - to type it). I didn't have any idea what it was for, but then I tried to type "Arial", which resulted in a-umlaut.

In my language we don't use those!