0
Pat 5 years ago • updated 5 years ago 1

I like to alternate between normal copy/paste (especially copying inside of ST and pasting into, for example, the browser) and vintage mode copy/paste. The problem is that vintage mode doesn't put the copied text in the clipboard, so I can't paste it with Ctrl+V (and even worse, my clipboard monitor tool can't pick up the copy).


I understand that there are multiple buffers for copy/paste in vim. I suggest always putting copied text into the clipboard as well as any particular buffer specified by the user. In essence, this would mean that paste (in any application) would always paste the content from the latest copy command, however it was performed.

+2

D'oh! Turns out this is already a setting in \Packages\Vintage\Preferences.sublime-settings called vintage_use_clipboard. I don't know why it defaults to false, but setting it to true gives me what I want.