+7

word_wrap setting is ignored.

Gábor Farkas 7 years ago • updated by Thomas Jachmann 6 years ago 4
i have the following in my UserFilePreferences:


{
"font_face": "Monaco",
"font_size": 12,
"tab_size": 4,
"translate_tabs_to_spaces": true,
    "word_wrap": true
}

but when i open python files, word_wrap is off.
the other settings from the preferences file are applied.

if i select word_wrap from the menu, it correclty switches word_wrap on.

i'm on osx, sublimetext 2, build 2020.
+1
The setting is getting overridden by the Python specific one. If you make a new file User/Python.sublime-settings, and place your word wrap setting in there, then it should apply.
Copy the "Python.sublime-settings" file into your User folder and modify it there.
The standard Python package sets its own wrapping rule which seems to override your settings.
I'm using php files and this problem happen when i opening files. I need to go on View menu and disable the option word_wrap. The word_wrap on file settings is ignored.


Sorry for my bad english, i'm brazilian and not write very good english.


Obrigado, (thanks)


My build is 2165

Syntax specific settings don't work either, they're just ignored - this used to work but stopped a few beta releases ago (I'm on 2180 now).

see http://sublimetext.userecho.com/topic/95538-syntax-specific-word_wrap-setting-is-ignored/